Is cloudflare.com agent ready?

cloudflare.com is largely agent ready: it scores 68/100 (grade B) on the w2agent rubric. Weakest areas: Content Quality (38).

68/ 100
Grade: B

Last checked · Platform: astro

Scored Oct 14, 2026 · Rubric v3.0

Changed since last check

No change in score since the previous check (2026-09-16)

Files added: MCP server card

Category scores

Technical
100
Agent Auth
56
Agent Discovery
75
Agent Protocols
66
Content Quality
38
Structured Data
84
Bot Accessibility
75

Agent protocol panel

  • A2A agent cardNot found
  • OAuth discoveryPresent
  • MCP discoveryPresent
  • llms.txt validityPresent

Check results

Bot Accessibility

  • ✓No error status codespass
  • ✗Response timefail
  • ✓XML sitemap existspass
  • ✓AI agent accesspass
  • ✓Edge treatment of agent user-agentstracked, not scoredpass
  • ✓robots.txt existspass
  • ✓Content negotiation (Markdown)pass
  • ✓Declared AI usage preferencestracked, not scoredpass

Structured Data

  • ✓OpenGraph meta tagspass
  • ✓Semantic HTML elementspass
  • ✓Appropriate Schema.org typepass
  • ✓JSON-LD validpass
  • ~Heading hierarchypartial
  • ✓Schema.org JSON-LD presentpass
  • ~Schema.org completenesspartial

Content Quality

  • ✓FAQ contentpass
  • ✗Answer-first contentfail
  • ✓Content lengthpass
  • ~Token efficiency (HTML-to-text ratio)partial
  • ✗Freshness signalsfail
  • ✗Author attributionfail
  • ✓Citation readinesspass
  • ~Lists and tables for structured infopartial

Agent Discovery

  • ✓llms.txt follows specpass
  • ✓llms.txt existspass
  • ✓MCP server cardtracked, not scoredpass
  • ✓Markdown alternate linkspass
  • ✗/.well-known/agent-card.jsonfail
  • ✓llms.txt links resolvepass

Agent Protocols

  • ✗Discoverable API endpointsfail
  • ✓MCP endpointpass
  • ✓Action schemaspass
  • ✗/.well-known/ucpfail
  • —Structured formsskip
  • ✓WebMCP imperative APItracked, not scoredpass
  • —WebMCP declarative APItracked, not scoredskip
  • ✓Reachable as Google-Agentpass
  • ✓Reachable as ChatGPT-Userpass
  • ✓Reachable as Perplexity-Userpass

Agent Auth

  • —MCP authorization (401 challenge → protected resource metadata)skip
  • ✓PKCE S256 supportpass
  • ✗Public API surfacefail
  • ✓Client ID Metadata Documents (bonus)pass
  • —OpenAPI specificationskip
  • ✗Agent/bot auth documentationfail
  • ✓OAuth discovery chain (RFC 9728 → RFC 8414)pass
  • ✓Developer portalpass
  • ✗Scoped API permissionsfail
  • —API catalog (RFC 9727)skip
  • —Agent operator signing directorytracked, not scoredskip

Technical

  • ✓HTTPSpass
  • ✓UTF-8 charsetpass
  • ✓Canonical URLspass
  • ✓Mobile viewportpass
  • ✓Content accessible without JSpass
  • ✓Security headerspass

Other

  • ✓astro-ssr-modepass
  • ✓astro-robots-txtpass
  • —ecommerce-gtin-validskip
  • —ecommerce-product-schemaskip
  • ✗astro-sitemap-integrationfail
  • —ecommerce-checkout-accessibleskip

Score history

  • 68/100 · rubric v3.0
  • 68/100 · rubric v3.0
  • 68/100 · rubric v3.0
  • 50/100 · rubric v2.0
  • 50/100 · rubric v2.0
  • 47/100 · rubric v2.0
  • 49/100 · rubric v2.0
  • 39/100 · rubric v2.0
  • 43/100 · rubric v2.0
  • 38/100 · rubric v2.0
  • 43/100 · rubric v2.0
  • 43/100 · rubric v2.0
  • 41/100 · rubric v2.0
  • 46/100 · rubric v2.0
  • 42/100 · rubric v2.0
  • 41/100 · rubric v2.0
  • 41/100 · rubric v2.0

Related websites